ServiceDiscoverEmitter Error registering service object

16:56:53.281 [main] INFO o.e.j.s.Server - Started @5456ms

16:56:53.284 [main] INFO c.l.l.l.LifeCycle - WebServer initialized

16:56:53.284 [main] INFO c.l.l.l.LifeCycle - FileServiceApplication initialized

16:56:53.287 [main] INFO c.l.l.l.LifeCycle - ServiceDiscoveryEmitter initialized

16:56:58.379 [pool-2-thread-1] ERROR c.l.l.p.s.ServiceDiscoveryEmitter - Error encountered registering the service object

javax.ws.rs.ProcessingException: RESTEASY004655: Unable to invoke request: java.net.UnknownHostException: service-registry.default: Name or service not known

at org.jboss.resteasy.client.jaxrs.engines.ApacheHttpClient4Engine.invoke(ApacheHttpClient4Engine.java:327) ~[resteasy-client-3.12.1.Final.jar:3.12.1.Final]

at org.jboss.resteasy.client.jaxrs.internal.ClientInvocation.invoke(ClientInvocation.java:443) ~[resteasy-client-3.12.1.Final.jar:3.12.1.Final]

at org.jboss.resteasy.client.jaxrs.internal.ClientInvocation.invoke(ClientInvocation.java:63) ~[resteasy-client-3.12.1.Final.jar:3.12.1.Final]

at org.jboss.resteasy.client.jaxrs.internal.ClientInvocationBuilder.post(ClientInvocationBuilder.java:227) ~[resteasy-client-3.12.1.Final.jar:3.12.1.Final]

at com.leidos.leaf.platform.servicediscovery.ServiceDiscoveryEmitter.invokeServiceRegistration(ServiceDiscoveryEmitter.java:190) ~[platform-services-service-discovery-3.2.1.jar:3.2.2]

at com.leidos.leaf.platform.servicediscovery.ServiceDiscoveryEmitter.registerService(ServiceDiscoveryEmitter.java:135) ~[platform-services-service-discovery-3.2.1.jar:3.2.2]

at com.leidos.leaf.platform.servicediscovery.ServiceDiscoveryEmitter.lambda$initialize$0(ServiceDiscoveryEmitter.java:96) ~[platform-services-service-discovery-3.2.1.jar:3.2.2]

Good afternoon Lennon!

Can you get me the following information?

  1. The result of kubectl get po -A
  2. The contents of the values.yaml file that this service was deployed with

The service is being deployed as a single docker image, not using kubernetes at the moment

Here is the values.yaml file

fullnameOverride: file-service
enableIngress: true
enableVirtualService: false
virtualService: |
gateways:

  • istio-system/istio-ingressgateway
    hosts:
  • ‘*’
    http:
  • match:
    • uri:
      prefix: /file-service/
      rewrite:
      uri: /
      route:
    • destination:
      host: file-service
      ingress:
      annotations:
      nginx.ingress.kubernetes.io/rewrite-target: /$2
      hosts:
    • hosts: “”
      paths:
      • /file-service(/|$)(.*)
        logging:
        serverLogLevel: info
        rootLogLevel: info
        probes:
        livenessProbe:
        initialDelaySeconds: 90
        servicePrefix: FileService
        selector:
        dataServiceType: transient
        eventServiceType: kafka
        kafka:
        producer:
        bootstrapServers: kafka.kafka:9092
        consumer:
        bootstrapServers: kafka.kafka:9092
        jaeger:
        sampler:
        type: const
        param: “1”
        sender:
        endpoint: http://jaeger-collector.observability:14268/api/traces
        reporter:
        logSpans: “true”

I see. So it would appear that the issue here is that you have an environment that is without a ServiceRegistry, and the FileService by default expects one (by way of service generation specifications).

There is currently a ticket out to make the emitter for the ServiceRegistry toggle-able, however in the meantime you can treat those errors as benign as they should not actually be breaking anything.

Please let me know if that all makes sense.

Understood. Thank you very much

1 Like

No problem!